Skip to main content

Troubleshooting

Common Errors

Failed to connect to the SMTP server

If this error occurs, access the Server settings and check the following in the Server section:

  • Verify the Server (SMTP) setting is specified correctly

  • Verify the Port Number for the mail server. If it is 25, Use Default can be checked, otherwise it should not be checked and the Port Number specified.

  • If the mail server requires encryption, ensure the correct Encryption setting is selected.

  • If the mail server is Gmail, you must create an App Password in your Google account and use that as the Password in the Logon Information section.

Failed to log into SMTP Server

If this error occurs, access the Server settings and check the following in the Logon Information section:

  • Verify the Name is correct. Some servers require this to be a complete email address (e.g., [email protected]) while others just require a name (e.g., fred).

  • Verify the Password for the specified Name. This is case sensitive.

  • For some mail servers, the Logon Information Name must match the Sender Information Email specified.

  • If the mail server is Office 365, Authenticate SMTP is not enabled by default for the user Name specified under Logon Information. This can cause a logon failure error when trying to send an email. To enable, an Office 365 administrator must open the Microsoft 365 Admin Center. In the Users, Active Users settings, Authenticate SMTP can be enabled for specific users.

Error Detail

If there is an error sending a message that cannot be easily diagnosed, a verbose error log can be generated to help troubleshoot the issue.

To do this, in the Log folder create a blank text file named maildebug.txt. When you attempt to send a message, if there is an error sending the message the file mailerror.txt is created. This file can be presented to SmartSights for further investigation.

Delete maildebug.txt from the Log folder to carry on normal operations.